Internet, Deporte y Educación

Página personal de Sergio Palay

Los secretos de la función BuscarV en Excel

Posted by sergiopalay en febrero 17, 2013

buscarvLa función BuscarV me permite ubicar un determinado valor en una columna a la izquierda de una tabla y devolver un valor en la misma fila en otra columna que nosotros indiquemos. Para ello debemos construir una tabla  auxiliar que sirva como referenciacon los valores buscados.

Veamos el siguiente ejemplo:

Supongamos que tenemos que averiguar el país en donde juegan cada uno de los jugadores.
Nos apoyaremos en la tabla auxiliar creada en el rango A13:B16
Lo primero que hacemos es pararnos en C4 y escribir la fórmula BUSCARV la cual tiene la siguiente sintaxis
=BUSCARV(valor buscado; matriz a buscar; nº columna; ordenado)

El valor buscado en este caso será el Equipo (siempre el campo tiene que coincidir en ambas tablas), la matriz a buscar es la tabla auxiliar, el nº de columna en este caso es la Nº 2 (las columnas se empiezan a numerar desde la primera columna de la tabla auxiliar), y en ordenado le ponemos no o dejamos libre (si pusiésemos sí y la tabla auxiliar está ordenada nos devuelve el valor inmediatamente siguiente al buscado si es que este no se encuentra)
Entonces nuestra función quedaría así:

  • BUSCARV(B4;$A$13:$B$16;2)

NOTA:
Muchas veces nos encontramos con el inconveniente que la función resuelve de forma correcta algunas filas y otras no. En esas aparece el símbolo #N/A
Esto se debe a que los datos de referencia (en este caso los equipos) no coinciden en ambas tablas. Procure revisar los mismos y recuerde que muchas veces cometemos el error de escribir una palabra y apretar de inmediato la barra espaciadora antes de dar Enter. Esto nos genera un carácter más en la cadena (para colmo de males invisible) y es la principal causa por la que las cadenas no coinciden.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: